SAASuite is a portal to all Measurand software for interacting with ShapeArrays. It provides access to a variety of Measurand applications. It also provides access to updates and beta versions of Measurand software. 

Measurand recommends a PC with the following minimum system requirements:

  • Windows 7 or higher operating system.
    • Please note, Windows Server 2008 R2, Windows Server 2012, and Windows Server 2012 R2 are exceptions to the compatible operating systems as they do not include the necessary Bluetooth components for SAARecorder
    • Measurand has tested SAASuite applications on systems with the most recent set of Window Updates installed. Measurand recommends installing all important updates from Microsoft for your operating before running SAASuite applications.
  • 2 GB RAM
  • Approximately 400 MB of hard drive space (this does not include space considerations for storing raw and converted ShapeArray data)
  • The system must have Microsoft .Net 4.0 or higher installed
  • One available USB 2.0 Port
NOTE: If you are unsure about the Microsoft .NET version, go to Control Panel -> Programs and Features. Scroll through the list of Programs to find the .NET version available. If it is less than 4.0, update to the newest .NET framework from Microsoft.



Getting Started with SAASuite


You first need to download SAASuite. To do this, navigate to the following URL:


http://measurand.ftpstream.com/?lid=nt7t2o2c


Click on the Measurand.Software.Installer_ver####.##.exe link and select a location to save the installer file. Click the Save button. Once downloaded, run the Measurand.Software.Installer_ver####.##.exe file. Click through the installation wizard to install SAASuite. Measurand recommends installing to the following default location: C:\Measurand Inc.


Figure 1: After you agree to the licensing agreement, you can select which components to install

NOTE: It is very important that SAASuite and its installed applications have read and write access to the folder in which they are installed. 


After SAASuite is installed, you need to use it to download the calibrations files for your ShapeArrays. Start SAASuite by double-clicking on the shortcut on the desktop or the SAASuite.exe file in the installation folder.


Figure 2: First launch of SAASuite - Click OK to close dialog and then click Get Calibration Files


Click the Get Calibration Files menu option, as shown in the figure above. This will open the Calibration Files window, as shown in the figure below. In this window, enter the serial number for your ShapeArray into the Serial Number field and click on the Get button. Repeat this for each ShapeArray you will be working with in the software. Alternatively, click on the Get All Calibration Files button to download and install calibration files for all ShapeArrays. 


Figure 3: Enter a serial number and click the Get button or click the Get all Calibration Files button


After the applications and calibration files have been downloaded and installed, you can close the Calibration Files window by clicking the Close button. 



Glossary of SAASuite Functionality


The main application window provides access to the most commonly used applications and utilities.


Figure 4: The SAASuite main application window

Menus


File Menu


The file menu contains two options: Settings and Exit. Selecting the Settings option opens a dialog where you can configure the following options.


Figure 5: The Settings dialog provides settings for updates and communication

  • Software Updates - When the checkbox is selected, SAASuite will check for updates each time the program is launched.
  • Software Download Options - Radio buttons allow you to select the communication protocol used for downloading Measurand software updates. By default, HTTP is selected for compatibility with most network firewalls; however, the FTP protocol can also be configured. 
  • Proxy Server Settings - If your computer connects to the Internet through a proxy server, you can configure the appropriate settings by selecting the checkbox and filling out the appropriate details. Please consult with your network administrator for more information on whether a proxy server is being used by your network.


Get Calibration Files Menu


The Get Calibration Files menu option opens the Calibration Files dialog where you can download calibration files for Measurand ShapeArrays. A calibration file is required by all Measurand software to properly connect to and work with data from the ShapeArray. You can download the calibration file for a specific ShapeArray by entering its serial number and clicking the Get button. Alternatively, all calibration files published can be downloaded and installed at once by clicking the Get All Calibration Files button.

Figure 6: The Calibration Files dialog allows you to download ShapeArray calibration files


Advanced Menu


The Advanced menu provides access to two utilities for working with files collected from Campbell Scientific data loggers and allows you to download beta versions of the Measurand software.

The following options provide access to the utilities for working with data logger files.

  • Check Logger Data - Launches the Data Checker program for visualizing raw ShapeArray data. This primarily used for diagnostic purposes.
  • Combine Multiple Logger Data - Launches the Raw2Raw_Concat utility for combining multiple raw data files for a single ShapeArray into a single file.

 

The Download Beta option in the Advanced menu allows you to download beta versions of the Measurand software. Beta versions of the software are provided on a case by case basis through interaction with the Measurand Support team. If a beta version of the software is available, Measurand's Support team will issue a code to access it. The beta code and a valid email address must be input before the beta software can be downloaded.

 Figure 7: To download beta software, a valid beta code and email address must be provided


Help Menu


The Help menu provides access to software updates, documentation, and Measurand support.

  • Check for Updates - Displays a dialog listing of the Measurand software currently installed, their version numbers, and the version numbers of the latest releases. The Update button on this dialog allows the latest versions of the software to be downloaded and installed.

Figure 8: The Updates dialog shows version information for the currently installed software and the latest releases from Measurand

  • Support - Opens a new browser window and navigates to the Measurand Support web site. This web site provides a searchable knowledge base of articles relating to all Measurand products and allows you to contact Measurand for assistance.
  • Software Newsletter - Opens a new browser window and allows you to sign up for the Measurand's Software newsletter.



Application Buttons


The application buttons are used to launch each individual Measurand application. They are labeled by the purpose of the application. Hovering over a button with the mouse cursor will reveal a tooltip indicating the software that will be launched by clicking it.  If the button is green, then the application or utility is installed and ready to use. If the button is grey then the application or utility is not installed. To update or install individual applications go to the Software Updates section below.

  • Manual Data Collection - Launches SAARecorder for manually connecting to a ShapeArray to collect readings or run diagnostic tests
  • Configure Logger Program - Launches File Generator to create programs for monitoring ShapeArrays with Campbell Scientific data loggers
  • Data Conversion - Launches Raw2Data to convert raw ShapeArray data collected from a Campbell Scientific data logger into Cartesian engineering units
  • ShapeArray Data Viewer - Launches SAAView to visualize converted ShapeArray data