Measurand's SAAView is used to visualize 3D or 2D data from ShapeArrays (SAAs). SAAView's AutoCall feature allows you to save view settings from the Unfiltered or Filtered Data View windows and then generate images of data using these settings from the command line. This is commonly used when automating data conversion with LoggerNet's Task Master.



Step 1 - Configure Data View Settings SAAView


Before images can be produced from the command line, view settings must first be configured and saved in SAAView. Open your data in SAAView and click on the ViewUnFiltered or ViewFiltered buttons to open one of the Data View windows. 


Figure 1: The ViewUnFiltered and ViewFiltered buttons in SAAView


In the Data View window, configure the view as desired. For example, select the graph type to be displayed from the View menu.


Figure 2: The View menu in the Unfiltered Data View window in SAAView



Step 2 - Save AutoCall Settings


Once you have configure the Data View window with the desired settings, open the Settings menu and click the AutoCall option. 


Figure 3: The Settings menu in the Data View window in SAAView


This will open the AutoCall Settings window. In one of the columns in this window, provide a short, memorable name for your view settings in the textbox. In the same column, select the checkbox for the ShapeArrays for which you wish to produce images using these settings. Also in the same column, click the Select radio button. Finally, click the Save button to save your AutoCall configuration. Repeat this process as many times as you wish for different views of the data, performing the above steps in a different column of the AutoCall Settings window each time.


Figure 4: The AutoCall Settings window


Once the AutoCall settings are saved, images of the configured data views can be created from the command line by executing the following command. 

NOTE: Please note that this command assumes that SAASuite was installed in the default location. If installed in a custom location, the path to the SaaView.exe file will need to be changed appropriately.


C:\Measurand Inc\SAA3D\SaaView.exe auto_call "[path to the project folder]" all_names


In the command above, the [path to the project folder] is the complete path to the logger project files. The quotes are required if the path contains spaces in the folder names. The all_names option is a list of the short, memorable names you used for your view settings, each separated by a space.



Step 3 - Optional, Configure LoggerNet Task Master for Automation


Once you have configured the AutoCall settings in SAAView, you can configure a command line task in LoggerNet's Task Master. This is done in the similar manner as described in the Setting Up Automated Data Conversions guide for configuring automated data conversion with SAACR_raw2data.

NOTE: The following step assumes you have configured automated data conversion with SAACR_raw2data as described in the Setting Up Automated Data Conversions guide.


In LoggerNet's Task Master, you add a second task to be executed after the first task (data conversion with SAACR_raw2data) finishes executing. This is done by right-clicking on the first task and selecting the Add After option from the menu. 


Figure 5: Adding a second task to Task Master that will execute after the task that runs SAACR_raw2data


This will add a second task to the Tasks pane that branches off from the first task. With the new task selected, click on the What Task_2 Does tab. On the Execute File tab, select the Execute File checkbox. Enter the following details in the appropriate fields:

  • File Name: C:\Measurand Inc\SAA3D\SAAView.exe
  • Command Line Options: auto_call "[path to the project folder]" all_names
  • Start In: C:\Measurand Inc\SAA3D

In the above settings, [path to the project folder] should be the path to your data logger project files. The quotes are required if the path contains spaces in the folder names. The all_names option is a list of the short, memorable names you used for your view settings, each separated by a space. 


To have the images generated in the background without displaying any windows, select the Run Minimized checkbox. Finally, click the Apply button to save your Task Master configuration.


Figure 6: Configuring the new task to execute SAAView from the command line with the auto_call option


Once data is automatically processed by SAACR_raw2data in the first Task Master task, the second task will execute SAAView from the command line and produce images with the following naming convention in the project folder with the data:


view_auto_[unique setting name]_[sernum].png


In the above file name, [unique setting name] refers to the short, memorable name you assigned to an AutoCall setting and [sernum] is the serial number of the ShapeArray.